ThatQuiz Бібліотека тестів Виконайте цей тест зараз
Роботи. - тест
Поширений: Шевченко
  • 1. Роботи - це машини, призначені для автоматичного виконання завдань, часто з точністю та ефективністю. Вони бувають різних форм і розмірів, від промислових роботів, що використовуються на виробництві, до людиноподібних роботів, які можуть допомагати в домашніх справах. З розвитком технологій, таких як штучний інтелект і машинне навчання, роботи стають все більш досконалими, здатними навчатися і адаптуватися до нових ситуацій. Хоча дехто може побоюватися, що роботи замінять людську працю, вони також мають потенціал покращити наше життя, беручи на себе небезпечні або повторювані завдання, звільняючи людей, щоб зосередитися на більш творчих починаннях.

    Що означає штучний інтелект по відношенню до роботів?
A) Штучний інтелект
B) Розширений інтерфейс
C) Аналіз та розслідування
D) Автоматизована інтеграція
  • 2. Який виробник роботів відомий завдяки створенню людиноподібного робота "ASIMO"?
A) Toyota
B) Sony
C) Хонда
D) LG
  • 3. Як звуть робота-компаньйона у фільмі "Волл-І"?
A) R2-D2.
B) БОЛТ
C) C-3PO.
D) ЄВА
  • 4. Який відомий робот відомий своєю крилатою фразою "Небезпека, Вілл Робінсон!"?
A) C-3PO.
B) Робот B-9
C) Оптимус Прайм
D) ВОЛЛ-І
  • 5. Як називалася система штучного інтелекту у фільмі "2001: Космічна одіссея"?
A) Мамо.
B) HAL 9000
C) Скайнет.
D) Альтрон.
  • 6. Яка робототехнічна компанія відома завдяки створенню модульної робототехнічної системи "Бакстер"?
A) Boston Dynamics
B) iRobot
C) Blue Origin
D) Переосмислити робототехніку
  • 7. Як називалася знаменита збірка науково-фантастичних оповідань Айзека Азімова, в якій були представлені три закони робототехніки?
A) Я, Робот.
B) Снігова катастрофа
C) Нейромант.
D) Чи мріють андроїди про електричних овець?
  • 8. Як називається здатність робота вчитися на власному досвіді та покращувати продуктивність з часом?
A) Віртуальна реальність
B) Бездротовий зв'язок
C) Соціальні мережі
D) Машинне навчання
  • 9. Якого відомого робота часто характеризують як такого, що хоче "винищити" людей?
A) Далек.
B) R2-D2.
C) Джонні 5
D) Бендере.
  • 10. Яка країна є світовим рекордсменом за кількістю роботів на 10 000 виробничих робітників?
A) Китай
B) Південна Корея
C) Німеччина
D) Японія
  • 11. Як називається процес програмування робота для виконання певного завдання шляхом демонстрації завдання роботу?
A) Глибоке навчання з підкріпленням
B) Штучні нейронні мережі
C) Генетичні алгоритми
D) Програмування за допомогою демонстрації
  • 12. Як називається здатність робота імітувати людські дії або вирази обличчя?
A) Артикуляція
B) Алгоритм
C) Антропоморфізм
D) Автоматизація
  • 13. Як зазвичай називають протокол виключення роботів?
A) meta-теги.html
B) sitemap.xml
C) robots.txt
D) crawler-rules.json
  • 14. Хто запропонував стандарт для файлу robots.txt у 1994 році?
A) Тім Бернерс-Лі
B) Вінт Серф
C) Чарльз Стросс
D) Мартін Костер
  • 15. Якою була первинна назва файлу robots.txt, коли його було запропоновано?
A) PageAccessControl.txt
B) RobotsNotWanted.txt
C) CrawlerExclusion.txt
D) WebBotRules.txt
  • 16. У якому році компанія Google запропонувала протокол виключення роботів (Robots Exclusion Protocol) як офіційний стандарт?
A) 2005
B) 1998
C) 2022
D) 2019
  • 17. Яка основна мета файлу robots.txt?
A) Зберігати облікові дані користувачів для входу.
B) Вказати, які розділи веб-сайту дозволено відвідувати веб-скаутерам.
C) Підвищити безпеку веб-сайту за допомогою шифрування.
D) Відображати рекламу.
  • 18. Де повинен знаходитися файл robots.txt на веб-сайті?
A) У файлах конфігурації сервера.
B) У кеші браузера користувача.
C) У кореневій директорії веб-сайту.
D) Всередині кожної директорії, до якої він застосовується.
  • 19. Що відбувається, якщо на веб-сайті відсутній файл robots.txt?
A) Сервер повертає помилку 404.
B) Веб-боти вважають, що немає обмежень на обхід та індексацію всього сайту.
C) Усі веб-сторінки автоматично індексуються.
D) Веб-сайт блокується пошуковими системами.
  • 20. Що робити, якщо веб-сайт має кілька піддоменів, і для кожного з них потрібен власний файл robots.txt?
A) Кожен піддомен повинен мати власний файл robots.txt.
B) Ігноруйте файл robots.txt для піддоменів.
C) Розмістіть один файл robots.txt у кореневій директорії.
D) Використовуйте один і той же файл robots.txt для всіх піддоменів.
  • 21. Чи можуть посилання на сторінки, перелічені у файлі robots.txt, з'являтися в результатах пошуку?
A) Ні, вони ніколи не з'являться в результатах пошуку.
B) Тільки якщо власник сайту схвалить це вручну.
C) Вони з'являються лише в тому випадку, якщо файл robots.txt відсутній.
D) Так, якщо на них є посилання з іншої сторінки, яку сканує пошукова система.
  • 22. Якою була основна проблема, пов'язана з перевантаженням серверів, коли вперше було впроваджено файл robots.txt?
A) Складні запити до бази даних.
B) Завантаження великих файлів користувачами.
C) Інтернет був достатньо малим, щоб підтримувати повний список усіх ботів.
D) Високе споживання трафіку через потокове відео.
  • 23. Який формат має містити файл robots.txt?
A) HTML-теги
B) Спеціальний текстовий формат
C) Двійковий код
D) Об'єкти JSON
  • 24. Яка організація опублікувала протокол заборони роботів (Robots Exclusion Protocol) як офіційний стандарт у вересні 2022 року?
A) Інститут інженерів електротехніки та електроніки (Institute of Electrical and Electronics Engineers, IEEE)
B) Міжнародна організація зі стандартизації (International Organization for Standardization, ISO)
C) Група з розробки інтернет-технологій (Internet Engineering Task Force, IETF)
D) Консорціум World Wide Web (World Wide Web Consortium, W3C)
  • 25. Які дії, що не рекомендуються організаціями, що встановлюють стандарти, при роботі зі шкідливими ботами, використовуючи файл robots.txt?
A) Використання міжмережевих екранів (файрволів).
B) Використання шифрування.
C) Впровадження систем CAPTCHA.
D) Захист шляхом приховування інформації.
  • 26. Яка мета використання файлу robots.txt у поєднанні з картами сайту?
A) Для шифрування передачі даних.
B) Для управління тим, які частини веб-сайту будуть проіндексовані та проскануті.
C) Для покращення візуального дизайну.
D) Для збільшення швидкості завантаження сторінок.
  • 27. Який номер RFC для запропонованого стандарту, опублікованого у вересні 2022 року?
A) RFC 2616
B) RFC 9309
C) RFC 3986
D) RFC 7230
  • 28. Яка потенційна причина використання файлу robots.txt на веб-сайті?
A) Щоб покращити апаратне забезпечення сервера.
B) Щоб покращити відтворення мультимедійного контенту.
C) Щоб запобігти відображенню певного контенту, який може бути оманливим або нерелевантним, у результатах пошуку.
D) Щоб збільшити кількість відвідувачів.
  • 29. Яке значення має файл robots.txt у юридичних справах, що стосуються ботів?
A) Він використовувався як підстава для судових позовів проти операторів ботів, які не дотримуються правил.
B) Суди завжди ігнорують файл robots.txt у таких випадках.
C) Суди вимагають створення файлів robots.txt для всіх веб-сайтів.
D) Судові справи показали, що файл robots.txt не має значення для роботи ботів.
  • 30. Які пошукові системи дотримуються стандарту robots.txt?
A) LinkedIn, WhatsApp, Telegram
B) Ask, AOL, Baidu, Bing, DuckDuckGo, Kagi, Google, Yahoo!, Yandex
C) Amazon, eBay, Alibaba
D) Facebook, Twitter, Instagram
  • 31. У 2023 році, скільки з тисячі найпопулярніших веб-сайтів заблокували бота GPT від OpenAI?
A) 50
B) 100
C) 500
D) 306
  • 32. Які компанії брали участь у запуску RSL?
A) LinkedIn, WhatsApp, Telegram
B) Amazon, eBay, Alibaba
C) Medium, Reddit, Yahoo
D) Google, Facebook, Twitter
  • 33. Який пошуковий робот інтерпретує параметр 'crawl-delay' як розмір часового інтервалу, протягом якого він буде отримувати доступ до сайту лише один раз?
A) Googlebot
B) BingBot
C) Yandex
D) Усі пошукові роботи
  • 34. Який максимальний розмір файлу robots.txt згідно з обмеженнями Google?
A) Без обмежень
B) 256 кілобайт
C) 500 кібібайт (512000 байт)
D) 1 мегабайт
  • 35. Яка директива, запроваджена компанією Cloudflare, визначає прийнятну поведінку для веб-сканувань?
A) Content-Signal
B) Crawl-delay
C) Sitemap
D) Disallow
  • 36. Який з цих пунктів не є частиною стандартного протоколу заборони для роботів (Robots Exclusion Protocol)?
A) Sitemap
B) Disallow
C) Crawl-delay
D) Allow
Створено з That Quiz — де тест з математики виконуються одним клацанням миші.